View Issue Details

IDProjectCategoryView StatusLast Update
0011018mantisbtwikipublic2012-12-11 17:06
Reportervipo Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.0rc2 
Summary0011018: dokuwiki Integration: multiple utf8 string wrapper redeclarations
Description

just installed 1.2.0rc2 and tried to integrate with dokuwiki (dokuwiki-2009-02-14b).
Calling the Wiki shows an empty page.

This is caused by:

library/utf8/substr_replace.php
library/utf8/mbstring/core.php

From Apache error.log:

PHP Fatal error: Cannot redeclare utf8_substr_replace() (previously declared in /usr/share/dokuwiki.mantis/inc/utf8.php:249) in /usr/share/mantisbt-1.2.0rc2/library/utf8/substr_replace.php on line 24

PHP Fatal error: Cannot redeclare utf8_strlen() (previously declared in /usr/share/dokuwiki.manti
s/inc/utf8.php:133) in /usr/share/mantisbt-1.2.0rc2/library/utf8/mbstring/core.php on line 28

Additional Information

wrapping each utf8 function with

if(!function_exists('utf8_xxx')){
}

solves this problem.

TagsNo tags attached.

Relationships

duplicate of 0011769 closeddregad Many cross-definitions of utf8 functions with dokuwiki 

Activities

combr

combr

2010-04-28 05:58

reporter   ~0025319

i have not rights to create relationship, but it links with 0011769

tiliarou

tiliarou

2011-01-24 12:17

reporter   ~0028052

what does that mean exactly ? :s
wrapping each utf8 function with

if(!function_exists('utf8_xxx')){
}

can I solve the bug without touching mantis sources ?
thanks in advance.

Issue History

Date Modified Username Field Change
2009-10-08 04:59 vipo New Issue
2009-10-08 04:59 vipo Status new => assigned
2009-10-08 04:59 vipo Assigned To => vboctor
2010-04-28 05:58 combr Note Added: 0025319
2011-01-07 18:19 vboctor Assigned To vboctor =>
2011-01-07 18:19 vboctor Status assigned => new
2011-01-07 18:20 vboctor Relationship added related to 0011769
2011-01-24 12:17 tiliarou Note Added: 0028052
2012-11-29 10:16 dregad Relationship replaced duplicate of 0011769
2012-11-29 10:16 dregad Status new => resolved
2012-11-29 10:16 dregad Resolution open => duplicate
2012-11-29 10:16 dregad Assigned To => dregad
2012-12-11 17:06 atrol Status resolved => closed