View Issue Details

IDProjectCategoryView StatusLast Update
0027067mantisbtfeaturepublic2020-07-22 17:01
Reportert18-orange Assigned Toatrol  
PrioritynormalSeveritytextReproducibilitysometimes
Status closedResolutionno change required 
Product Version2.24.0 
Summary0027067: $g_show_realname problem
Description

I have set '$g_show_realname' to ON in my config file.
This configuration file also has "g_timeline_view_threshold" set to VIEWER or ANYBODY.

display does not change from username to realname.

TagsNo tags attached.

Activities

atrol

atrol

2020-07-03 14:44

developer   ~0064146

I am not able to reproduce using the given information.
Please provide step by step instructions how to reproduce on a fresh install.

t18-orange

t18-orange

2020-07-05 22:38

reporter   ~0064151

Migrated from version 1.0.6 to 2.24.0.

However, I do not bring in the old version of the conf file, and I am using the new version of the conf file as is.
DB dump is executed and only DB data is migrated.

New environment
・Amazon Linux release 2 (Karoo)
・Apache / 2.4.41
・5.5.64-MariaDB
・PHP 7.4.4

atrol

atrol

2020-07-06 17:05

developer   ~0064152

Still missing

Please provide step by step instructions how to reproduce on a fresh install.

t18-orange

t18-orange

2020-07-07 06:03

reporter   ~0064155

install matnis2.24.0
/var/www/html/config_defaults_inc.php

$g_show_realname = ON;
$g_show_user_realname_threshold = ANYBODY;
atrol

atrol

2020-07-07 14:18

developer   ~0064160

/var/www/html/config_defaults_inc.php

Never ever change this file. Always use the original one of the Mantis download.
Configuration is done in file config/config_inc.php

And still:
I am not able to reproduce using the given information.
Please provide step by step instructions how to reproduce on a fresh install.

This should be something like

  • Install Mantis 2.24.0
  • Create private project P1
  • Create user U1 with access level REPORTER
  • ...
t18-orange

t18-orange

2020-07-07 22:45

reporter   ~0064162

I am very sorry

After setting in /var/www/html/config/config_inc.php, the display changed to realname.

atrol

atrol

2020-07-08 06:09

developer   ~0064163

Thanks for the feedback @t18-orange

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2020-07-03 03:00 t18-orange New Issue
2020-07-03 14:44 atrol Status new => feedback
2020-07-03 14:44 atrol Note Added: 0064146
2020-07-05 22:38 t18-orange Note Added: 0064151
2020-07-05 22:38 t18-orange Status feedback => new
2020-07-06 17:05 atrol Status new => feedback
2020-07-06 17:05 atrol Note Added: 0064152
2020-07-07 06:03 t18-orange Note Added: 0064155
2020-07-07 06:03 t18-orange Status feedback => new
2020-07-07 14:18 atrol Status new => feedback
2020-07-07 14:18 atrol Note Added: 0064160
2020-07-07 22:45 t18-orange Note Added: 0064162
2020-07-07 22:45 t18-orange Status feedback => new
2020-07-08 06:09 atrol Assigned To => atrol
2020-07-08 06:09 atrol Status new => resolved
2020-07-08 06:09 atrol Resolution open => no change required
2020-07-08 06:09 atrol Note Added: 0064163
2020-07-22 17:01 atrol Status resolved => closed