View Issue Details

IDProjectCategoryView StatusLast Update
0027123mantisbtjavascriptpublic2021-03-07 18:29
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-beta.1 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027123: MantisGraph: stop using chart.js bundled build
Description

The plugin currently links both chart.js and chart-bundle.js, which is not necessary. The latter includes Moment.js, which is already part of MantisBT since 2.0 (see layout_body_javascript() function), so using the stand-alone build should be sufficient.

According to documentation [1] this could even cause compatibility issues, although this does not seem to be the case for us.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 4e82e3a5

2020-05-26 03:36:30

dregad

Details Diff
MantisGraph: stop using chart.js bundled build

The plugin currently links both chart.js and chart-bundle.js, which is
not necessary. The latter includes Moment.js, which is already part of
MantisBT since 2.0 (see layout_body_javascript() function), so using
the stand-alone build should be sufficient.

According to documentation [[1]] this could cause compatibility issues.

Fixes 0027123

[1]: https://www.chartjs.org/docs/latest/getting-started/installation.html#bundled-build
Affected Issues
0027123
mod - plugins/MantisGraph/MantisGraph.php Diff File
rm - plugins/MantisGraph/files/Chart.bundle-2.8.0.min.js Diff File