BUG: SQL Causes Note formatting to mess up

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
Some Pdx Dev
Posts: 2
Joined: 17 Jan 2020, 15:41

BUG: SQL Causes Note formatting to mess up

Post by Some Pdx Dev »

Hi. This was observed using version 2.17.0. I'm not sure if this bug has been fixed. I tried to report this bug in bug tracker, but my account doesn't seem to work there.

For the most part we have no issues with our MantisBT install. But yesterday I saw something very odd. I edited a note (in red below), and when I add the note everything that follows on the page (Time Tracking, Issue History, etc) appears as part of my note.

The note which I added is:

Working on bugs 2. and 3. as these should be related to the same files.

Fixed bug 2.

Bug 3 - determined the issue was caused likely by an update to entity framework where the DateTime datatype is sent to sql server as the sql server datetime2 datatype.

Removed .bak file for the Finished Goods Default.cshtml.

select schema_name(t.schema_id) + '.' + t.name as ,
c.name as column_name,
type_name(user_type_id) as data_type,
scale as second_scale,
from sys.columns c
join sys.tables t
on t.object_id = c.object_id
where type_name(user_type_id) in ('date', 'datetimeoffset',
'datetime2', 'smalldatetime', 'datetime', 'time') and type_name(user_type_id) = 'datetime'
order by

... I added colour here just for emphasis.

If I remove the SQL from this note the ticket displays properly. If I re-add the SQL, the Time Tracking, Issue History, appears once again as part of my note (and not separate sections following my note).

See the screenshot below.

When I edit the note, it's only contents are what you see coloured above.

Is this fixed in the later versions of MantisBT? I'm unable to upgrade the version we use at work.
mantis edited.png
mantis edited.png (494.6 KiB) Viewed 1833 times
Some Pdx Dev
Posts: 2
Joined: 17 Jan 2020, 15:41

Re: BUG: SQL Causes Note formatting to mess up

Post by Some Pdx Dev »

I will note, however, that today while editing the same note on the same ticket I'm unable to reproduce the issue.

Yesterday when I had the issue, multiple times I could add/remove that SQL from the note to see the bug appear, then disappear. And I tried several times adding/removing the SQL.
Post Reply