Page 1 of 1

How to debug "Manage Mailboxes" settings not persisting?

Posted: 06 Jan 2021, 23:20
by seanm
Hi all,

So I'm trying the EmailReporting plugin for the first time. I'm using the version from git master with mantis from git master also.

I've made changes in "Manage Configuration Options" and those are saved/remember correctly. But when I set things in "Manage Mailboxes" then press the "Add" button, it doesn't remember anything (like mail server host name, etc.).

How do I debug this?

Also, the 'select mailbox' option presents a popup menu with 4 items, all of which are blank. What to make of that?
Screen Shot 2021-01-06 at 17.09.09.png
Screen Shot 2021-01-06 at 17.09.09.png (36.95 KiB) Viewed 487 times
Thanks,

Sean

Re: How to debug "Manage Mailboxes" settings not persisting?

Posted: 07 Jan 2021, 17:34
by SL-Gundam
Since the entries are blank. Did you give the entry a description? or did you leave it blank?
Check the "Manage configuration" -> "Configuration Report". Find the value called "plugin_EmailReporting_mailboxes"

Re: How to debug "Manage Mailboxes" settings not persisting?

Posted: 10 Jan 2021, 22:34
by seanm
Ah, I see, that's supposed to be a list of things added using the fields above it? I thought it was a list of my user's IMAP mailboxes. I thought it was failing to retrieve the IMAP folder list from the mail server.

Might I suggest that the 'description' field should be mandatory. There's not much sense it allowing it to be blank it seems.

Re: How to debug "Manage Mailboxes" settings not persisting?

Posted: 11 Jan 2021, 13:09
by SL-Gundam
Maybe not much sense yes. But the description is just for you. EmailReporting does not need it.
You can edit those entries and change the empty descriptions to something else.