Content Security Policy blocking upgrade

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
mnemonicator
Posts: 16
Joined: 28 May 2018, 13:56

Content Security Policy blocking upgrade

Post by mnemonicator »

Hello, don't understand why, but for some reason i see that admin/install.php looks wrong, when i open developer tools in chrome i found many red lines with next comments -
Refused to load the stylesheet '<URL>' because it violates the following Content Security Policy directive: "style-src 'self' 'unsafe-inline'". Note that 'style-src-elem' was not explicitly set, so 'style-src' is used as a fallback.
I test this many times in UAT environment and don't have this problem, the only one difference between Prod and UAT is that Prod is available from internet.

Here is a screenshot - https://1drv.ms/u/s!AsfZfWuNH0Qvgd1iULU ... w?e=KsEJmV

Any ideas?

thank you.
cas
Posts: 1069
Joined: 11 Mar 2006, 16:08
Contact:

Re: Content Security Policy blocking upgrade

Post by cas »

Search for CSP here, you will find your answer :mrgreen:
mnemonicator
Posts: 16
Joined: 28 May 2018, 13:56

Re: Content Security Policy blocking upgrade

Post by mnemonicator »

thx.

$g_path variable was set in a config_inc.php and tis fix my problem.
Post Reply