Custom field in filter > error: Bad Request - PHP 8.0.7 - Mantis 2.25.1

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
fxm
Posts: 24
Joined: 01 Feb 2007, 09:42
Location: Namur (Belgium)

Custom field in filter > error: Bad Request - PHP 8.0.7 - Mantis 2.25.1

Post by fxm »

Hi all,

I installed last version of PHP (8.0.7) and since this moment I receive a "error: Bad Request" when I select a custom field in the filter of "view issue" page.

PhpMyAdmin works with success

Nevertheless, I can create and see issues using these custom fields.

It occurs whatever is the custom fields type and with Mantis version 2.25.1 or 2.24.3.

Where can I have a look in order to have logging ? Any idea or tips with this issue ?

Thanks you
François
Attachments
BadRequest Mantis.PNG
BadRequest Mantis.PNG (15.72 KiB) Viewed 368 times
Last edited by fxm on 14 Jun 2021, 14:11, edited 2 times in total.
atrol
Site Admin
Posts: 7959
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Custom field in filter > error: Bad Request - PHP 8.0.7 - Mantis 2.25.1

Post by atrol »

Seems to be the same like viewtopic.php?f=3&t=27436
I tried this some weeks ago on a PHP 8.x system and was able to reproduce the issue.

Please enter a bug report on https://www.mantisbt.org/bugs
Please use Search before posting and read the Manual
fxm
Posts: 24
Joined: 01 Feb 2007, 09:42
Location: Namur (Belgium)

Re: Custom field in filter > error: Bad Request - PHP 8.0.7 - Mantis 2.25.1

Post by fxm »

Hi atrol,

I confirm, I seems to be the same. But I cannot go back to PHP 7 due to security issues in PHP 7.

I reported a bug as asked (https://www.mantisbt.org/bugs/view.php?id=28803)

Thanks for your support
Post Reply